Unverified Commit 9d8c9a65 authored by Adrian Schollmeyer's avatar Adrian Schollmeyer
Browse files

metadata: Add news item about gst-plugins-fdkaac split



Since the split of the fdkaac plugin from gst-plugins-bad involves
manual intervention by users, this commit adds a news item explaining
the procedure.
Signed-off-by: Adrian Schollmeyer's avatarAdrian 'nex' Schollmeyer <adrian.schollmeyer@fem.tu-ilmenau.de>
parent 109a1618
Pipeline #2712 failed with stages
in 2 minutes and 17 seconds
Title: gst-plugins-bad splits off fdkaac plugin
Author: Adrian Schollmeyer <adrian.schollmeyer@fem.tu-ilmenau.de>
Posted: 2022-04-24
Revision: 1
News-Item-Format: 2.0
Display-If-Installed: >=media-libs/gst-plugins-bad-1.18.4
gst-plugins-bad was imported into the FeM Overlay to add support for the
fdkaac plugin. In the Gentoo Bugzilla, Bug #837809 [1] has been opened,
requesting addition of the fdkaac plugin. The maintainers have decided to make
the fdkaac plugin available in a split package. As soon as the split package
gets added to ::gentoo, the cleanup of gst-plugins-bad in the FeM Overlay
shall start.
To ease with the transition, a split package media-plugins/gst-plugins-fdkaac
has been created, which is equivalent to the package in the open pull request.
The current revision of media-libs/gst-plugins-bad in the FeM Overlay pulls in
media-plugins/gst-plugins-fdkaac conditionally if the fdk USE flag is present.
However, to make sure the plugin doesn't get removed in the next deplean,
users must add the package to the world set:
emerge --ask --noreplace media-plugins/gst-plugins-fdkaac
[1] https://bugs.gentoo.org/837809
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment